Active Issue Alert – Blackbaud ID – Multiple Products - 000525013
Incident Report for Blackbaud
Resolved
We are no longer seeing widespread customer impact due to this issue and have seen user login and MFA activity return to pre-incident levels. We will be marking this incident as resolved.

If you continue to have an issue logging in, please chat with our Support team to review other potential causes.

As a final reminder, customers receiving the "Oops something went wrong" error should review and apply changes for their networking systems:
https://kb.blackbaud.com/knowledgebase/articles/Article/192072
Posted Apr 29, 2024 - 11:30 EDT
Update
We are seeing a greatly reduced number of login issues today, but continue investigating the "Oops something went wrong" errors occurring for a small subset of users. The next scheduled update is 04/29/24 at 11 AM ET.

Customers receiving the "Oops something went wrong" error should review and apply changes for their networking systems: https://kb.blackbaud.com/knowledgebase/articles/Article/192072
Posted Apr 26, 2024 - 17:14 EDT
Update
Customers who are continuing to experience "Oops something went wrong" error should review and apply changes for their networking systems: https://kb.blackbaud.com/knowledgebase/articles/Article/192072
Reports of users experiencing 'wrong error codes' have decreased and Engineers are continuing to triage issues as they are raised. The next scheduled update is 04/26 at 5PM ET.
Posted Apr 26, 2024 - 11:26 EDT
Update
Engineers continue investigating the "Oops, something went wrong" error that are impacting a small subgroup within Email/Password users authenticating with MFA and continue to triage issues as they are raised. The next scheduled update is 04/26 at 11AM ET.
Posted Apr 25, 2024 - 16:38 EDT
Update
We have deployed an updated Recovery Phone Number option for users of Mobile authenticator applications who have previously configured a recovery phone number. Mobile auth app users receiving "wrong code" errors, or similar issues while entering their code, may use this self-serve option to reset their MFA.

We continue investigating the "Oops, something went wrong" error and will provide a further update later today. Engineers will provide the next update at 5:30PM ET. Please continue to reference this page for updates.
Posted Apr 25, 2024 - 15:39 EDT
Investigating
With looping issues addressed and "wrong code" errors decreasing, we are now seeing reports of the error "Ooops, something went wrong." We are working with our third-party vendor to resolve this as quickly as possible. The next update will be provided no later than tomorrow, 4/25/2024, at 10:30 AM EDT.
Posted Apr 25, 2024 - 00:09 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud.com (Blackbaud.com, signin.blackbaud.com, Blackbaud ID), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™), Blackbaud Altru®, Blackbaud eTapestry®, Blackbaud Guided Fundraising™, Blackbaud Internet Solutions™, Financial Edge®, Raiser's Edge®, ResearchPoint™, Blackbaud Financial Edge NXT® (Financial Edge NXT), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).