Active Issue Alert – Luminate Online - #000686818

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 15:13 EDT

Investigating

Our engineers have identified an issue impacting a subset of customers, leading to HTTP 500 errors when attempting to access dev sites. Our engineers are actively working to identify the cause and restore full functionality as quickly as possible. Please continue to monitor this page for updates.
Posted Aug 05, 2026 - 14:41 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).