Informational – Blackbaud Merchant Services Operational - #000086858
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 14, 2019 - 09:29 EST
Update
We have identified an issue with processing direct debit transactions which caused transactions processed between Sunday, November 10th at 4:30 AM EST and Tuesday, November November 12th at 12:40 PM EST to enter a state of "Validation Error" with a result message of "General System Failure". At this time, direct debit batches in Raiser's Edge and Blackbaud CRM can be re-proceeded, but please do not re-process other direct debit transactions that failed with this error during this window until we are able to determine the results of these charges. Next update 9 AM EST.
Posted Nov 13, 2019 - 17:28 EST
Monitoring
We have identified an issue with processing direct debit transactions which caused transactions processed between Sunday, November 10th at 4:30AM EST and Tuesday, November November 12th at 12:40PM EST to enter a state of "Validation Error" with a result message of "General System Failure". At this time, direct debit batches in Raiser's Edge and Blackbaud CRM can be re-proceeded, but please do not re-process other direct debit transactions that failed with this error during this window until we are able to determine the results of these charges. Next update 5PM EST
Posted Nov 13, 2019 - 12:05 EST
This incident affected: Blackbaud Merchant Services (Blackbaud Merchant Services).