Maintenance Overage - Critical Maintenance 58897 - Email Services
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 00:31 EDT
Identified
Maintenance ID [58897] - The maintenance that was scheduled to complete on [07/24/2024] at [11:00 PM EST] has been extended to [01:00 AM EST].
This maintenance is necessary to perform an update to the environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Jul 24, 2024 - 23:02 EDT
This incident affected: Email Services.