Active Issue Alert – Blackbaud Merchant Services - #000117364
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 15, 2020 - 21:34 EDT
Update
We have identified an issue impacting some of our customers when refunding transactions. Users are experiencing a processing error. At this time please do not continue attempting to process refunds until this issue is resolved. Next update will be on 3/16 at 12 PM ET
Posted Mar 15, 2020 - 12:04 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 15, 2020 - 11:18 EDT
This incident affected: Blackbaud Merchant Services (Blackbaud Merchant Services).