Active Issue Alert – Blackbaud Church Management, Raiser's Edge NXT - #000151020
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 20, 2020 - 22:56 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. The Next Update will be at 5:00 PM ET.
Posted Jul 20, 2020 - 15:28 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. The Next Update will be at 3:00 PM ET.
Posted Jul 20, 2020 - 14:09 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. The Next Update will be at 2:00 PM ET.
Posted Jul 20, 2020 - 12:02 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 20, 2020 - 11:44 EDT
This incident affected: Blackbaud Church Management and Raiser's Edge NXT (Raiser's Edge NXT).