Resolved Issue Alert – Raiser's Edge NXT – #2019041703
Incident Report for Blackbaud
Resolved
We identified an issue impacting a subset of our Raiser's Edge NXT customers when using Database View. Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.
Posted Apr 17, 2019 - 02:33 EDT