Active Issue Alert – Blackbaud CRM, Altru - #2019041001
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 10, 2019 - 14:52 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 10, 2019 - 14:23 EDT
Monitoring
We have identified an issue where a subset of customers are unable to retrieve reports. This is not affecting donations or transactions. We are continuing to monitor for any further issues, we are continuing to monitor progress for CRM and Altru customers after the fix was implemented. We are working to ensure service is restored for all customers as quickly as possible. Please continue to reference this page for updates. We will provide a new update in one hour.

Resolved - An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Apr 10, 13:05 EDT

Identified - We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue and have all the appropriate engineers working to address it for you. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Apr 10, 12:34 EDT

Investigating - We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Apr 10, 12:02 EDT
Posted Apr 10, 2019 - 13:37 EDT
This incident affected: Blackbaud Altru® and Blackbaud CRM™.