Maintenance Overage 65512 - Multiple Services Affected
Incident Report for Blackbaud
Resolved
The scheduled maintenance has been completed.
Posted Apr 07, 2021 - 04:28 EDT
Identified
Maintenance ID 65512 - The maintenance that was scheduled to complete on Apr 07, 2021 at 03:00 AM EST has been extended to 05:00 AM EST.
This maintenance is necessary to perform an update in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Apr 07, 2021 - 03:21 EDT
This incident affected: Blackbaud CRM™, Blackbaud Internet Solutions™, Blackbaud NetCommunity™, Financial Edge®, and Raiser's Edge®.