Grant making - 000630295

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 11:30 EDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2025 - 11:29 EDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2025 - 11:24 EDT

Investigating

Grant Making user receives error when attempting Publishing
Posted Aug 27, 2025 - 11:06 EDT
This incident affected: Blackbaud Grantmaking™ (Blackbaud Grantmaking™).