Active Issue Alert – Email Services - 000553756
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. Email campaigns that were queued are now being sent and may take some time to catch up. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 17, 2024 - 14:23 EDT
Update
We are aware of an issue where email sending was intermittently disrupted. Engineers are diagnosing and working to address the issue as quickly as possible. In the interim, we have paused email sends for the following products:
• Blackbaud NetCommunity
• Blackbaud Internet Solution/Blackbaud Enterprise CRM
• Blackbaud Altru
• Blackbaud Tuition Management
• Blackbaud ID
• Online Express
• Blackbaud Education Management solutions

Emails are being queued and will send when the issue is resolved.
Posted Sep 17, 2024 - 11:18 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates. As of 10:47 AM EDT, 09/17/2024, we will be queueing mail to be sent once this issue has been resolved.
Posted Sep 17, 2024 - 10:51 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 17, 2024 - 10:05 EDT
This incident affected: Blackbaud Online Express™ (Blackbaud Online Express™), Blackbaud Altru®, Blackbaud CRM™, Blackbaud Internet Solutions™, Blackbaud Tuition Management™, Email Services, Blackbaud.com (Blackbaud ID), and Blackbaud Education Management Solutions (Core Functionality).