Active Issue Alert – Blackbaud Merchant Services - #000088808
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 20, 2019 - 15:28 EST
Monitoring
We've identified an issue impacting a subset of our Blackbaud Merchant Services clients processing credit card batches. Some batches processed are still in status Gateway Processing and have not completed. Please do not cancel or reprocess the batches to prevent duplicates at this time. Next update 3PM EST
Posted Nov 20, 2019 - 14:08 EST
Identified
We've identified an issue impacting a subset of our Blackbaud Merchant Services clients processing credit card batches. Some batches processed are still in status Gateway Processing and have not completed. Please do not cancel or reprocess the batches to prevent duplicates at this time. Next update 2PM EST
Posted Nov 20, 2019 - 12:31 EST
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 20, 2019 - 12:19 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).