CITRIX RECEIVER USERS
Incident Report for Blackbaud
Resolved
If you’re unable to connect to your Blackbaud solution, you may need to upgrade your Citrix Receiver version. For more information and how to upgrade, visit http://upgrade.blackbaud.com.
Posted Apr 20, 2018 - 09:10 EDT
Monitoring
If you’re unable to connect to your Blackbaud solution, you may need to upgrade your Citrix Receiver version. For more information and how to upgrade, visit http://upgrade.blackbaud.com.
Posted Apr 17, 2018 - 23:00 EDT