Maintenance Overage 19102509104418 - Luminate CRM
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Nov 09, 2019 - 11:19 EST
Identified
Maintenance ID 19102509104418 - The maintenance that was scheduled to complete on 11/09/2019 at 9:00:00 AM has been extended to 11:00:00 AM.
This maintenance is necessary to perform updates in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Nov 09, 2019 - 08:45 EST
This incident affected: Luminate CRM.