An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 04, 2024 - 12:19 EDT
Investigating
We are aware of issues causing delays or inability to log in to database view or other features within Raiser's Edge NXT. Engineers are diagnosing the issue to resolve it as quickly as possible.
Posted Oct 04, 2024 - 11:57 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).