Active Issue Alert – Blackbaud ID - 000395745
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 28, 2022 - 18:47 EDT
Update
We are currently seeing multifactor authentication issues when using SMS and MMS delivery methods.
Currently those using authenticator applications are not affected. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 28, 2022 - 14:35 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 28, 2022 - 14:30 EDT
This incident affected: Blackbaud.com (Blackbaud ID).