Active Issue Alert – Online Express - #2019091001
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 10 days ago. Sep 10, 2019 - 17:58 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted 10 days ago. Sep 10, 2019 - 17:45 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 10 days ago. Sep 10, 2019 - 17:19 EDT
This incident affected: Online Express (Online Express).