Active Issue Alert – Luminate Online - 000680368

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jun 24, 2026 - 21:40 EDT

Update

We have identified an issue that is preventing participants from creating a Facebook fundraiser from their Participant Center. Our engineers are currently working with Meta to address this issue.
Posted Jun 24, 2026 - 11:48 EDT

Identified

We have identified an issue that is preventing participants from creating a Facebook fundraiser from their Participant Center. Our engineers are currently investigating.
Posted Jun 23, 2026 - 18:56 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).