Active Issue Alert – Blackbaud CRM - 000271084
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 29, 2021 - 12:56 EDT
Identified
We have identified an issue impacting some of our customers. Our engineers are working to resolve the event and restore service for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 29, 2021 - 12:53 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jul 29, 2021 - 12:17 EDT
This incident affected: Blackbaud CRM.