Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Aug 12, 2026 - 14:26 EDT
Investigating
We have identified an issue that may cause some users to experience intermittent failures when loading navigation elements or accessing applications within the solutions listed below. We’re working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Aug 12, 2026 - 14:15 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™, Blackbaud Learning Management System, Blackbaud Student Information System™, Core Functionality, School API, Blackbaud Billing Management™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud.com (Blackbaud.com), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™), Blackbaud Altru®, Blackbaud eTapestry®, Blackbaud Tuition Management™, ResearchPoint™, WealthPoint®, DonorCentral® NXT, Blackbaud Raiser's Edge NXT® (Constituent API, Fundraising API, Gift API, Opportunity API, Raiser's Edge NXT®), and Blackbaud Merchant Services™ (Payments API).