Active Issue Alert – Blackbaud Checkout - #2019090903
Incident Report for Blackbaud
Resolved
The issue impacting using the Visa Checkout payment type is now resolved. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 9 days ago. Sep 11, 2019 - 13:12 EDT
Update
We have identified an issue impacting some of our customers wherein using the Visa Checkout payment type resulted in unexpected behavior. Our engineers are working with Visa to resolve it for you as quickly as possible. In the interim, we have removed the Visa Checkout option. Please continue to reference this page for updates. The next update will be provided at 9:00 AM EDT on September 12th.
Posted 10 days ago. Sep 11, 2019 - 07:44 EDT
Update
We have identified an issue impacting some of our customers wherein using the Visa Checkout payment type resulted in unexpected behavior. Our engineers are working with Visa to resolve it for you as quickly as possible. In the interim, we have removed the Visa Checkout option. Please continue to reference this page for updates. The next update will be provided at 9:00 AM EDT
Posted 10 days ago. Sep 10, 2019 - 19:04 EDT
Update
We have identified an issue impacting some of our customers wherein using the Visa Checkout payment type resulted in unexpected behavior. Our engineers are working with Visa to resolve it for you as quickly as possible. In the interim, we have removed the Visa Checkout option. Please continue to reference this page for updates. The next update will be provided at 5:00 PM EDT.
Posted 11 days ago. Sep 10, 2019 - 12:11 EDT
Update
We have identified an issue impacting some of our customers wherein using the Visa Checkout payment type resulted in unexpected behavior. Our engineers are working with Visa to resolve it for you as quickly as possible. In the interim, we have removed the Visa Checkout option. Please continue to reference this page for updates. The next update will be provided at 12:00 PM EDT.
Posted 11 days ago. Sep 10, 2019 - 09:00 EDT
Identified
We have identified an issue impacting some of our customers wherein using the Visa Checkout payment type resulted in unexpected behavior. Our engineers are working with Visa to resolve it for you as quickly as possible. In the interim, we have removed the Visa Checkout option. Please continue to reference this page for updates. The next update will be provided at 9:00 AM EDT.
Posted 11 days ago. Sep 09, 2019 - 19:53 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 11 days ago. Sep 09, 2019 - 17:13 EDT
This incident affected: Blackbaud Payment Service.