Active Issue Alert – Blackbaud Grantmaking™ - #000693959

Incident Report for Blackbaud

Update

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Next update 8:00 AM EST on Sep 22nd. Please continue to reference this page for updates.
Posted Sep 21, 2026 - 16:20 EDT

Update

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Next update 5:00 PM EST Please continue to reference this page for updates.
Posted Sep 21, 2026 - 12:23 EDT

Investigating

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Next update 12:00 PM EST Please continue to reference this page for updates.
Posted Sep 21, 2026 - 10:39 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 21, 2026 - 06:11 EDT

Identified

Customers in the UK may experience issues uploading documents within Blackbaud Grantmaking. Our engineering team has identified the issue and is actively working toward a resolution. The incident bridge is currently paused pending additional support and is scheduled to reconvene at 8:00 AM EST. We will provide further updates as more information becomes available.
Posted Sep 21, 2026 - 06:09 EDT

Investigating

..
Posted Sep 21, 2026 - 06:06 EDT

Identified

..
Posted Sep 21, 2026 - 06:06 EDT

Update

..
Posted Sep 21, 2026 - 06:01 EDT

Investigating

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 21, 2026 - 05:20 EDT
This incident affects: Blackbaud Grantmaking™ (Blackbaud Grantmaking™).