Active Issue Alert – Email Services - 000250230
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted May 11, 2021 - 09:53 EDT
Identified
We have identified an issue affecting a subset of our customers that is preventing emails from being sent. Engineers are working to determine root cause and will then implement a permanent fix. In the meantime, affected customers should not attempt to resend emails. Though not sending, they are queuing and will be sent once the issue is resolved.
Posted May 11, 2021 - 09:28 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 11, 2021 - 08:48 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 11, 2021 - 08:09 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 11, 2021 - 07:37 EDT
This incident affected: Blackbaud Altru®, Blackbaud CRM™, Blackbaud Internet Solutions™, Blackbaud NetCommunity™, Email Services, Blackbaud Financial Edge NXT® (Financial Edge NXT), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).