Active Issue Alert – Raiser's Edge NXT® - #000633983

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 17, 2025 - 10:14 EDT

Update

We are investigating an issue impacting a subset of Raisers Edge NXT customers. Users attempting to access the donor portal invitation on an iOS device or the safari browser on a MAC OS device many experience intermittent failure. Our engineers continue their efforts to diagnose the issue and resolve it as quickly as possible. The next update will be at 10:00 AM EST on 9/16/2025.
Posted Sep 15, 2025 - 17:23 EDT

Investigating

We are investigating an issue impacting a subset of Raisers Edge NXT customers. Users attempting to access the donor portal invitation on an iOS device or the safari browser on a MAC OS device many experience intermittent failure. Our engineers continue their efforts to diagnose the issue and resolve it as quickly as possible. Please continue to reference this page for updates.
Posted Sep 15, 2025 - 11:34 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).