Active Issue Alert – Luminate - 000659914

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 15:41 EST

Investigating

We have identified an issue that impacted a subset of customers causing sites to be inaccessible. Our engineers have restored service and sites are accessible again.
Posted Feb 19, 2026 - 15:23 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).