An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 15, 2024 - 09:31 EST
Update
We have identified an issue impacting some of our Blackbaud Tuition Management payers attempting to make payments using Mastercard. Our engineers are working to understand the issue and resolve it as quickly as possible. As a work around, payers can utilize other payment methods until the issue is resolved.
Posted Nov 14, 2024 - 13:16 EST
Update
We have identified an issue impacting some of our Blackbaud Tuition Management payers attempting to make payments using Mastercard. Our engineers are working to understand the issue and resolve it as quickly as possible. As a work around, payers can utilize other payment methods until the issue is resolved.
Posted Nov 14, 2024 - 13:14 EST
Update
We have identified an issue impacting some of our Blackbaud Tuition Management payers attempting to make payments using Mastercard. Our engineers are working to understand the issue and resolve it as quickly as possible. As a work around, payers can utilize other payment methods until the issue is resolved. Please continue to reference this page for updates.
Posted Nov 14, 2024 - 13:04 EST
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 14, 2024 - 12:32 EST
This incident affected: Blackbaud Tuition Management™.