A subset of customers are receiving the message "Error saving records" when trying to import or process a global change for constituent data. Our engineers are investigating the issue and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 26, 2026 - 12:37 EST
Identified
A subset of customers are receiving the message "Error saving records" when trying to import or process a global change for constituent data. Our engineers are investigating the issue and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 26, 2026 - 12:03 EST
Update
A subset of customers are receiving the message "Error saving records" when trying to import or process a global change for constituent data. Our engineers are investigating the issue and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 26, 2026 - 11:21 EST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2026 - 11:16 EST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2026 - 11:12 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 26, 2026 - 11:10 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®) and Raiser's Edge®.