Active Issue Alert –Team Approach - #2019081302
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 13, 2019 - 13:49 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted about 1 month ago. Aug 13, 2019 - 13:45 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted about 1 month ago. Aug 13, 2019 - 12:54 EDT
This incident affected: Team Approach.