Some AU payouts scheduled for April 3rd, 2025 are delayed. We expect that these payouts will be processed on April 7th, 2025. We are continuing to monitor the situation closely and will provide updates as they become available.
Posted Apr 06, 2025 - 21:06 EDT
Investigating
We have identified a delay in payment disbursements on April 3rd affecting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 06, 2025 - 20:35 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).