An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 30, 2024 - 20:25 EDT
Update
We are aware of an issue where Verizon mobile users are experiencing errors completing multi-factor authentication for Blackbaud ID. This impacts both SMS and MFA Mobile Authenticator App users. MFA Mobile App users may connect to a wi-fi network to successfully receive MFA messages. We will update this page as we receive updates on restoration of service from Verizon.
Posted Sep 30, 2024 - 15:17 EDT
Identified
Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Sep 30, 2024 - 15:15 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.