Maintenance Overage 20060906460258 - Blackbaud NetCommunity
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 12, 2020 - 07:51 EDT
Identified
Maintenance ID 20060906460258 - The maintenance that was scheduled to complete on 07/12/2020 at 7:00:00 AM has been extended to 8:00:00 AM.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Jul 12, 2020 - 07:07 EDT
This incident affected: Blackbaud NetCommunity™.