Our engineers identified additional impact to a subset of donors using Apple devices attempting to donate through the modal Checkout experience and made changes overnight to resolve this issue. Our monitoring indicates an immediate improvement following the changes, and the issue is now resolved.
Posted Jul 23, 2026 - 10:12 EDT
Monitoring
Our engineers have deployed a patch to mitigate this issue impacting a subset of donors using the modal Checkout experience in eCommerce/Calendar Events. We are monitoring the results. The next update will be at 10am ET on 7/23. Please continue to reference this page for updates.
Posted Jul 22, 2026 - 22:01 EDT
Identified
Our engineers have deployed a patch to mitigate this issue impacting a subset of donors using the modal Checkout experience in eCommerce/Calendar Events. We are developing an additional patch to mitigate this issue further. The next update will be at 10am ET on 7/23. Please continue to reference this page for updates.
Posted Jul 22, 2026 - 21:03 EDT
Investigating
We have identified an issue impacting a subset of donors using the modal Checkout experience in eCommerce/Calendar Events. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 22, 2026 - 15:02 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).