Active Issue Alert – Blackbaud Luminate Online & Payment Services - 000595019

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 21, 2025 - 16:39 EDT

Identified

We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 21, 2025 - 16:38 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®) and Payment Services.