Active Issue Alert – Luminate Online - #2019082501
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 27 days ago. Aug 25, 2019 - 10:28 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 27 days ago. Aug 25, 2019 - 09:55 EDT
This incident affected: Luminate (Luminate Online).