Active Issue Alert – Multiple Products - 000390481
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 23:18 EDT
Update
We are continuing to investigate this issue.
Posted Sep 20, 2022 - 23:02 EDT
Update
We are continuing to investigate this issue.
Posted Sep 20, 2022 - 22:45 EDT
Update
We are continuing to investigate this issue.
Posted Sep 20, 2022 - 22:36 EDT
Update
We are continuing to investigate this issue.
Posted Sep 20, 2022 - 22:35 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 20, 2022 - 22:19 EDT
This incident affected: Luminate (Luminate Online), Raiser's Edge NXT (Raiser's Edge NXT), and Email Services.