Maintenance Overage 23051511501336- BB Church Management
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted May 26, 2023 - 04:54 EDT
Identified
Maintenance ID 23051511501336 - The maintenance that was scheduled to complete on 05/26/2023 at 3:00am EST has been extended to 5:00am EST.
This maintenance is necessary to perform a routine task in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted May 26, 2023 - 02:59 EDT