Active Issue Alert – Blackbaud Tuition Management - #000102205
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 22, 2020 - 07:43 EST
Identified
Please be aware of an issue impacting the payments dashboard page. Currently, this page is not loading any payment data. Please see the payments tile for most recent payments made or use custom reports until this issue is resolved. Next update will be 1/22 at 11:00 AM ET.
Posted Jan 21, 2020 - 11:22 EST
This incident affected: Blackbaud Tuition Management™.