Active Issue Alert – Blackbaud Payment Service - #2019081504
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 15, 2019 - 14:08 EDT
Monitoring
Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates. Please do not reprocess batches at this time.
Posted about 1 month ago. Aug 15, 2019 - 13:25 EDT
Identified
We have identified an issue impacting some of our customers using batch processing. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please do not reprocess batches at this time.
Posted about 1 month ago. Aug 15, 2019 - 12:32 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted about 1 month ago. Aug 15, 2019 - 12:13 EDT
This incident affected: Blackbaud Payment Service.