Active Issue Alert – Blackbaud Church Management - #2019083004
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 21 days ago. Aug 30, 2019 - 18:14 EDT
Update
We have identified an issue impacting some of our Blackbaud Church Management customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted 21 days ago. Aug 30, 2019 - 17:36 EDT
Investigating
We have identified an issue impacting some of our Blackbaud Church Management customers causing errors when attempting to add Volunteer Opportunities. Some customers are receiving the error "Cannot save data, Try again soon.". Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 21 days ago. Aug 30, 2019 - 16:58 EDT
This incident affected: Blackbaud Church Management.