Active Issue Alert – Payment Services, Raiser's Edge NXT and Blackbaud Billing Management - 000575878
Incident Report for Blackbaud
Monitoring
We have made a configuration change that should address this issue for new transactions moving forward. Gifts that received this error were not charged and must be re-processed. Customers may resubmit transactions to be charged during the next processing window.

Billing Management users can review and resubmit impacted transactions from the Review Failed Payments list. RENXT users can review and resubmit impacted transactions from the Gifts List.

Please contact Blackbaud Customer Support for assistance reviewing or re-submitting the gifts for processing. We will remain in an extended monitoring period to ensure re-submissions are processing successfully. Any further updates will be provided on this page.
Posted Jan 02, 2025 - 14:03 EST
Update
Updating to include Blackbaud Billing Management as an impacted product. Billing Management users can review and resubmit impacted transactions from the Review Failed Payments list.

Please contact Blackbaud Customer Support for assistance reviewing or re-submitting the gifts for processing.
We will post another update to this page no later than 5 PM EST.
Posted Jan 02, 2025 - 13:36 EST
Identified
We have identified the cause of this issue and are working to resolve it. Gifts that received this error were not charged and must be re-processed. Customers may resubmit transactions to be charged during the next processing window.

To identify and resubmit impacted transactions in Raiser's Edge NXT, users may approve batches and check the Gifts List afterwards. Please contact Blackbaud Customer Support for assistance reviewing or re-submitting the gifts for processing.
We will post another update to this page no later than 5 PM EST.
Posted Jan 02, 2025 - 13:17 EST
Update
Users may have received a “General System Failure” error message for direct debits processed via batch on 1-1-25. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jan 02, 2025 - 12:36 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jan 02, 2025 - 12:12 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jan 02, 2025 - 12:03 EST
This incident affects: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®), Blackbaud Education Management Solutions (Blackbaud Billing Management™), and Payment Services.