Maintenance Overage - 22080506345327 - Altru
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 04:55 EDT
Identified
Maintenance ID 22080506345327 - The maintenance that was scheduled to complete on 8/17/2022 at 3:00am EST has been extended to 5:00am EST.
This maintenance is necessary to perform an update in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Aug 17, 2022 - 03:11 EDT
This incident affected: Blackbaud Altru®.