Active Issue Alert – Blackbaud Raiser's Edge, Blackbaud Financial Edge - #000668747

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 20:30 EDT

Monitoring

We have made a configuration change based on the findings of our diagnostic teams and vendor guidance.  We expect this change to prevent further SSL errors upon login to database view.  This incident is moving into a monitoring state to ensure the update works as expected. Please continue to reference the status page for confirmation of resolution or any other further updates which may occur.
Posted Apr 14, 2026 - 09:03 EDT

Update

A subset of users are receiving the error "Failed to connect to the server because of an SSL error" when attempting to login to database view. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 13, 2026 - 16:57 EDT

Update

A subset of users are receiving the error "Failed to connect to the server because of an SSL error" when attempting to login to database view. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 13, 2026 - 16:42 EDT

Investigating

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 13, 2026 - 16:18 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT) and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).