Active Issue Alert – BBID - Multiple Products - 000665599

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 16:10 EDT

Monitoring

We continue to see stable login response times and reduced navigation errors following recent configuration changes. We will continue to monitor system performance to ensure ongoing stability. Please continue to reference this page for updates.
Posted Mar 24, 2026 - 14:46 EDT

Update

We are receiving reports of 504 Gateway Errors and Timeout Errors across our systems. Our engineers are investigating the issue and will provide updates here.
Posted Mar 24, 2026 - 13:46 EDT

Update

We are receiving reports of 504 Gateway Errors and Timeout Errors across our systems. Our engineers are investigating the issue and will provide updates here.
Posted Mar 24, 2026 - 13:26 EDT

Update

We are receiving reports of 504 Gateway Errors and Timeout Errors across our systems. Our engineers are investigating the issue and will provide updates here.
Posted Mar 24, 2026 - 13:21 EDT

Investigating

We are receiving reports of 504 Gateway Errors and Timeout Errors across our systems. Our engineers are investigating the issue and will provide updates here.
Posted Mar 24, 2026 - 13:04 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™, Blackbaud MobilePay™, Payments API, Blackbaud MobilePay Terminal), Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™, Blackbaud Outcomes™), Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud.com (Blackbaud.com, signin.blackbaud.com, Support, Blackbaud ID), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™, FPM Data Integration), Blackbaud Luminate Online® (Luminate CMS, Luminate Integration, Blackbaud Luminate Online®, Luminate WebServices, Team Raiser), and Blackbaud Altru®, Blackbaud CRM™, Blackbaud eTapestry®, Blackbaud Guided Fundraising™, Blackbaud Internet Solutions™, Blackbaud Tuition Management™, Blackbaud Website Package, Financial Edge®, JustGiving® from Blackbaud®, Raiser's Edge®, ResearchPoint™.