Active Issue Alert – Blackbaud Payment Service - #2018071703
Incident Report for Blackbaud
Resolved
We are aware of an issue where our customers may have experienced credit card processing failures for approximately 50 minutes. Our partner has resolved the issue and we are continuing to monitor the situation.
Posted Jul 17, 2018 - 21:57 EDT
Investigating
We have identified an issue impacting some of our customers ability to process payments. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 17, 2018 - 21:46 EDT
This incident affected: Payment Services.