An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 10, 2025 - 09:46 EDT
Update
We are aware of an issue where users may encounter the error: "An unknown error has occurred" when navigating the application, or pages within Altru may refresh or reload. Engineers are investigating to resolve it as quickly as possible. Please reference this page for further updates.
Posted Jul 10, 2025 - 09:29 EDT
Investigating
We are aware of an issue where users may encounter the error: "An unknown error has occurred" when navigating the application, or pages within Altru may refresh or reload. Engineers are investigating to resolve it as quickly as possible. Please reference this page for further updates.