Active Issue Alert – Altru - 000261206
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jun 18, 2021 - 18:27 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Jun 18, 2021 - 17:48 EDT
Update
We are continuing to investigate this issue.
Posted Jun 18, 2021 - 17:17 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jun 18, 2021 - 16:49 EDT
This incident affected: Blackbaud Altru®.