Active Issue Alert – Blackbaud ID – Multiple Products - #000290271
Incident Report for Blackbaud
Resolved
We recently resolved an issue that prevented users from signing in or using features in their solutions. You should now be able to sign in to your Blackbaud solutions and services with your Blackbaud ID.
Posted Sep 28, 2021 - 12:29 EDT
Identified
We diagnosed an issue that may prevent anyone from signing in with their Blackbaud ID or using features in the solutions below. We’re working to resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Sep 28, 2021 - 12:04 EDT
This incident affected: Financial Edge NXT (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud Grantmaking (Blackbaud Grantmaking), Blackbaud Education Management Solutions (Blackbaud School Website System, Blackbaud Enrollment Management System, Blackbaud Learning Management System, Blackbaud Student Information System), Raiser's Edge NXT (Constituent API, Fundraising API, Gift API, Opportunity API, Raiser's Edge NXT), Altru, Blackbaud Employee Giving, Blackbaud Employee Volunteering, DonorCentral NXT, eTapestry, WealthPoint, and Blackbaud Merchant Services (Payments API).