Maintenance Overage 20031105475844 - Online Express
Incident Report for Blackbaud
Resolved
The scheduled maintenance has been completed.
Posted Mar 18, 2020 - 00:21 EDT
Identified
Maintenance ID 20031105475844 - The maintenance that was scheduled to complete on 03/18/2020 at 12:00:00 AM EST has been extended to 2:00:00 AM.
This maintenance is necessary to perform an update in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Mar 18, 2020 - 00:08 EDT
This incident affected: Blackbaud Online Express™ (Blackbaud Online Express™).