Active Issue Alert – Blackbaud Employee Giving, Blackbaud Employee Volunteering, Blackbaud Grantmaking, Donor Central, Host*Net/FIMS/IGAM - #2018051505
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted May 15, 2018 - 21:51 EDT
Update
We have identified an issue impacting some of our customers whose products are hosted out of the New Jersey datacenter. A major storm has caused a full service interruption at that location. Our engineers are working closely with our vendor to provide a full restoration of services as soon as possible. Please continue to reference this page for updates. Next update will be provided in 2 hours or when more information becomes available.
Posted May 15, 2018 - 21:05 EDT
Investigating
We have identified an issue impacting some of our customers whose products are hosted out of the New Jersey datacenter. A major storm has caused a full service interruption at that location. Our engineers are working with our vendor to provide a resolution as soon as possible. Please continue to reference this page for updates.
Posted May 15, 2018 - 19:44 EDT