Resolved Issue Alert – Financial Edge and Raiser's Edge - 000379561
Incident Report for Blackbaud
Resolved
We identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues.

Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.

Please continue to reference this page for updates.
Posted Aug 10, 2022 - 12:33 EDT
This incident affected: Financial Edge and Raiser's Edge.